Turbo Gears Environment - TurboGears

What is Turbo Gears Environment?

Prerequisite

Python 2.6 or higher. Earlier versions of TurboGears were not compliant with Python 3.X. Latest version claims to work well on Python 3.X. However, official documentation of TurboGears is still based on Python 2.7 environment.

The following command installs virtualenv −

This command needs administrator privileges. Add sudo before pip on Linux/Mac OS. If you are on Windows, log in as Administrator. On Ubuntu virtualenv may be installed using its package manager.

Once installed, the new virtual environment is created in a folder.

To activate corresponding environment, on Linux/OS X

On Windows

We are now ready to install TurboGears in this environment. A minimal installation of TurboGears is done by following command −

The above command can be run directly without virtual environment for system wide installation.

To install TurboGears along with development tools, use following command −

All rights reserved © 2018 Wisdom IT Services India Pvt. Ltd DMCA.com Protection Status

TurboGears Topics