jBPM5 Eclipse Plugin - jBPM

how to install jBPM5 Eclipse Plugin?

Below are the Prerequisites for installing jBPM Plugin

  • Java 1.5 (or higher) SE JDK
  • Eclipse 4.2 or any version and the jBPM plugin

As jBPM is written in Java and as most of the Java developers use Eclipse, we will explain how to add the jBPM plugin in Eclipse.

Download the binaries from below link − http://download.jboss.org/drools/release/5.3.0.Final/

Don't get confused by seeing Drools here. Same plugins will be used for jBPM. If Drools plugin is already installed on your system, you can skip the installation steps.

download_binaries

Extract it to your hard disk, then launch Eclipse and go to Help → Install New Software.

install_new_software

Click Add Repository

add_repository

Click the Local button and then select ".../binaries/org.drools.updatesite" (where you downloaded on your machine)

available_software

Select Drools and jBPM and then click the Next button.

install_detail

Again, Click Next and select “I accept the terms of license agreement” and then click Finish. The software installation will start

software_installation_starts

After successful installation, you will get below dialog box

successful_installation

Click Yes. Eclipse restarts. Now, go to Windows → Preferences → Drools → Drools Flow Nodes

drools_flow_nodes

If you can see the nodes as shown in the above screenshot, it means that the plugins are successfully installed. Now you are ready to write the first jBPM program.

All rights reserved © 2018 Wisdom IT Services India Pvt. Ltd DMCA.com Protection Status

jBPM Topics