Requirements for .NET application development with DB2 - IBM DB2

The following requirements are needed to develop .NET application solutions with DB2 data source:

  • DB2 client (minimum DB2 Application Development Client) Version 8.1.2 for use of DB2 .NET Data Provider and Version 8.1.5 for OLE DB bridge provider needs to be installed and the appropriate database needs to be cataloged.
  • To develop and run applications that use DB2 .NET Data Provider, the .NET Framework Version 2.0 or 1.1 is required. The .NET Framework version 2.0 is recommended for new DB2 solutions development.
  • For Visual Studio 2005 add-in, Microsoft Visual Studio 2005 is required and DB2 Application Development Client V8.2 fix pack 10 or later.
  • For Visual Studio 2005 add-in, Windows XP, Service Pack 2, or later, or Windows Server® 2003, Service Pack 1.

DB2 .NET Data Provider can be used to connect to the following data sources:

  • DB2 Universal Database for Linux, UNIX, and Windows, Version 9
  • DB2 Universal Database Version 8 for Windows, UNIX, and Linux-based computers
  • DB2 Universal Database Version 6 (or later) for OS/390 and z/OS, through DB2 Connect
  • DB2 Universal Database Version 5, Release 1 (or later) for AS/400 and iSeries, through DB2 Connect

To ensure that the ADO.NET applications built for DB2 UDB V8 can function successfully with DB2 9, they need to be migrated. This may involve rebuilding the application if DB2 .NET Data Provider is used.

All rights reserved © 2018 Wisdom IT Services India Pvt. Ltd DMCA.com Protection Status

IBM DB2 Topics